- ' Driving Analog Innovation

New Features in Tanner EDA v15.10

December 2010




Tanner EDA v15.10 New Feature Summary

= S-Edit
» Library Write Access Enhancements
* Improved Bus, Port, and Nethame Processing
»  Spice Hierarchical Netlist Import
+ Additional Corner Simulation Settings
+ Addition of Monte Carlo Simulation Settings

= W-Edit
* New Histogram Chart
* New Eye Diagrams
* New Chart Style Setup

* Copy to Clipboard or Save Charts as Windows Metafiles *. wmf
* Import/Export of Traces from/to a File or Clipboard

= T-Spice
* Improved Performance

* Updated Models
« Simulation Files/Folders Can Now be Easily Renamed

= L-Edit
* Improved Wire Drawing With Vias

* Snap to Intersection
*  SDL Jump to Schematic

= HiPer Verify
+ DRC/ Extract Speed Improvement

= HiPer DevGen
— Added Resistor Arrays
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S-Edit: Library Write Access Enhancements

= Improved control over write permissions allows users to choose to open a design with Exclusive or Non-
Exclusive access

= Opening a design with Exclusive Access reserves the right to save a design, so that no-one else can write
to it while you have it open. This “write reservation” gives you the exclusive right to save a design

= Opening a design with Non-Exclusive Access means you might be able to write to the design in the future,
as long as no one else secures a write reservation before you attempt to save the design

Open Design r$_<|

File:

Libraries

RingHCO |

| umentsiTanner EDA\Tanner Tools 15, 1DesignsiRingWCOVRINgYCO . tanner ﬂ

Access opkions

 RinghCo
@ Generic_250nm_Devices
& SPICE_Elements

libr aties & Misc

@ SPICE_Commands

" Attempt exclusive access

¢~ Bttempt exclusive access of top-level design, and non-exclusive access of al

* MNon-exclusive access of top-level design and all libraries

Exclusive access prevents anyone else from writing ko the design on disk, guaranteeing
that wou will be able to save any changes you make,

You might be able ko save changes wou make when vou have non-exclusive access, but it
is not guaranteed.

When you save a design without exclusive access and the design has not been modified
on disk since you opened it, S-Edit kries to get exclusive access, IF it succeeds, the save

proceeds,
K | Cancel |

add... |
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S-Edit: Improved Bus, Port, and Netname
Processing

= |f multiple buses (with different dimensions) connect to a single net, S-Edit will now connect
all the buses to this single net

— Prior to v15.10 this would be an error due to the connection of busses with different dimensions

e Devices With SPICE.QRD
Rk kK ':':,p Leye] *%xkikk N
MMnl<0O> N 1 In Gnd Bulk NMO325
MMnl<l> N 2 In Gnd Bulk NMO325
MMnl<2> N 3 In Gnd Bulk NMO325
MMpl<O> N 4 In Vdd Bulk PMO325
MMpl<l> N 5 In Vdd Bulk PMO325
MMpl<Z> N 6 In Vdd Bulk PMO325
MMpl<3> N 7 In Vdd Bulk PMO325 2
< | 3 .
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S-Edit: Spice Hierarchical Netlist Import

= Spice, Verilog and EDIF import will now create SPICE Text views.

— Spice views will be now saved with the design
= Importing a hierarchical netlist will create separate cells for each subcircuit in the netlist

Ring¥CO_TestBench.sp * by

* Organization: Tanner EDAL - Tanner Research, Inc.
% Info: Testhench for RingVCo

% Date: 1Z/Z0/2010 5:56:13 AN

* Revision: 63 § §x=7600 §y=600 w=3600 §h=1200
EEEREEAERAEAL S SUNCIECUITS FEEERERARRE AR A S L

-subckt Control ¥Tune Vbl Vhi Vhias Gnd Vdd

MMSn N_2 N_2 Vhias 0 NMOSZ5 W=1.5u L=250n M=1 Ai5=975f P5=4.3u AD=975f PD=4.3u § §u=3907 $y=3400

+5h=600 §m

MHMén ¥h2 N_Z N_3 0 NMO3ZS5 0U=1.5u L=Z50n M=1 A%=S75f P3=4.3u LD=8975f FD=4.3u § §x=4593 jy=3400 &y
+§h=600

MMTn M 3 VTune Gnd O NMOS25 W=1.5u L=250n M=1 LZ=975f PZ=4%.3u AD=375f PD=4.3u § $x=5307 §y=2700
+3h=600 $m

MMip N 1 Vhl Wdd Vdd PMOS25 W=5u L=250n M=1 A5=3.25p P3=11.3u AD=3.25p PD=11.3u § §x=3907 §Jy=500
+3h=600 $m
MMZp Vb1 Vbl Wdd Vdd PMOS25 W=5u L=250n M=1 AL5=3.25p P5=11.3u AD=3.25p PD=11.3u § §x=4593 §y=500

+§h=600
MM3p N_2 VhZ ©N_1 Vdd PMO3ZS W=5u L=250n M=1 A353=3.25p FP3=11.3u AD=3.z25p FD=11.3u § §x=3907 §{y=42 nl:ontrol:spice"‘ I
+3h=600 $m

MMd4p VbZ VhZ Vbl Vdd PMO325 W=5u L=250n N=1 A3=3.25p P¥=11.3u AD=3.25p PD=11.3u § $x=4593 $y=420 - I‘ Imported from file C:\Docuwents and Settings)shaswa)Desktop' temp) RingWC0 TestBench.sp
+§h=600 ]

-ends - .subckt Control VTune Wbl Vhi Vhias Gnd Vdd

ekt DifColl Tom Tne Outm Outm TTune Vi VBE Gud Ved To.0n MMip N 1 Vbl Vad Vdd PMOS25 U=5u L=250n N=1 A5=3.25p PS=11.3u AD=3.25p PD=11.3u h=600
sEvRERE DALTERLD Tmn fap Sk bubp Thune ™ B MMzp Vbl Vbl vdd Vdd PMOS25 T=5u L=250m M=1 A5=3.25p PS=11.3u AD=3.25p PD=11.3u h=600

MN1 Cutm VTune Gnd Gnd NMOSZS W=1.5u L=2u M=1 AS=075f PS=4.3u AD=975f PD=4.3u § §x=4007 $y=2600 MM3p N 2 Vhz N_1 Wdd PMO3Z5 W=5u L=z50n M=1 A3=3.235p PE=11.3u LD=3.25p FD=11.3u h=600
+$h=600 im MM4p Vhi Vb2 Vhl Vdd PMOSZS5 W=5u L=250n M=1 AL3=3.25p P3=11.3u ALD=3.25p FD=11.3u h=600
MNZ Outp VTune Gnd Gnd NMOSZS W=1.5u L=2u H=1 k3=975f P3=4.3u LD=075f PD=4.3u § §x=4233 jy=2600 MMSn N 2 N 2 Vbias Gnd NMOSZ5 W=1.5u L=250n M=1 AS=975f P53=4.3u AD=975f FD=4.3u h=600
+§h=600 MMén Vb2 N_2 N_3 Gnd NMOSZS W=1.5u L=Z50n M=1 A3=975f P3=4.3u AD=975f PD=4.3u h=600
Ny gy bl Vod VAd PHOSZS WSSu Lo2SOn N ASS3.25p PSTIL.3u ADTS.25p PDTAL.3u € fxmazss fymsiod MM7n N_3 VTune Gnd Gnd NMOS2S5 W=1.5u L=250n N=1 AS=975f FS=4.3u AD=975f FD=4.3u h=600
MPZ N 2 VB2 N_1 Vdd PMOS25 W=5u L=250n M=1 k3=3.25p PE=11.3u AD=3.25p PD=11.3u § §x=4293 §y=4400 -ends

+§h=500

HP3 Cutm Inp N 2 Vdd PMOSZ5 W=W L=250n M=1 A3='g50n*W' P3='1l.3u+2*W' AD='B50n*W' PD='1l.,3u+2*W' S._
+3y=3600 §w=414 $h=600

MP4 COutp Inm N_2 Vdd PMOSZS5 W=W L=250n M=1 i5='650n*W' P5='1l.3u+27W' AD='G650n*W' PD='1l.3u+Z7*W' 4
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S-Edit: Additional Corner Simulation Settings

= Multiple .alter commands can now be inserted in a table format

— Parameters, Temperature, Libraries, and TCL scripts can be added as variables

— A desired value can be added as a corner

— File > Export > SPICE has a check box to “Create separate files for each corner” so that consecutive results are not
overwritten

M Setup SPICE Simulation of cell ‘RingVCO_TestBench®

General

Metlisting Options

Hierarchy Priority

Additional SPICE Commands
Parameters

SPICE Oplions

DC Operating Point Analysis
Transient {Fourier Analysis
] D Sweep Analysis

1 AC Analysis

1 Moise Analysis

[] Transfer Function Analysis
[] Temperature Sweep
Parameter Sweep

Cornet Simulations

Carnet Simulations

‘ariable Type

Generic_250nm.lib  Library

Mew Corner...

Mew Yariable...

Run Simulation

.

Caneel

T TransientAnalysis.sp *

FEEFEEEET Corners FEEEEEEEE

.TITLE Low
.PARAM Cap=5f
.LIB "Generic 250nw Tech/Generic 250nm.lik"™ 535

.ALTER Normal

.DEL LIE "Generic_z.SDn.m_TechfGeneric_ZSDnm. lib™ 53
.PARAM Cap=30f

.LIE "Generic_2SDnm_Tech,.-’Generic:_ZSDn.m. lik™ TT

.ALTER High

.DEL LIE "Generic:_ZSDn.m_TechfGeneric_ZSDnm. lib™ TT
.PARAM Cap=50f

.LIE "Generic_2SDn.m_Techf"Generic_ZSDn.m. lik™ FF
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S-Edit: Monte Carlo Simulation Settings

= A Monte Carlo sweep option has been added to the applicable analysis options

Il Setup SPICE Simulation of cell ‘Inverter_TestBench'

General =
Metlisting Options Skop Time 300ns
Hierarchy Priority Mazximum Time Step 250ps
Additional SPICE Commands Print Start Time
Parameters Print Time Step
SPICE Options Use Initial Conditions False
Skartup Mode Powerup

D S Analysi =
] WEED_ nalysis Enable Fourier Analysis false
1 AC Analysis R

R . Fourier Fundamental Frequency

[] Moise Analysis

Qubput Variables
Fourier Mumber of Harmaonics
Fourier Mumnber of Points

[] Transfer Function Analysis
[ ] Temperature Sweep

[] Parameter Sweep
[] Corner Simulations Interpolate Data Points true

20

Monte
The number of Monte Catlo simulations.

T MonteCarloAnalysis_Inverter_TestBench_Inverter.sp

FrEFEFEAL Simnlation Settings - Analysis Section & FFFEAES

.op
.tran/Powerup 250p 300n|swveep monte=Z2Z0

..

v, S
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W-Edit: New Histogram Chart

= Results of .measure commands in Monte Carlo simulations are now automatically plotted on
a histogram chart

! Chartl {Histogram)

anner T-Spics 15.10 C:Documants 524 Sattings fspir My Documents Tanner EDA Tenner Tools v1S.1 SimulatiorRasults Invarter [nverter. TastBanch MonteCarloAnalysis Tnvarer TestBench lnvarter.sp
— RizeTime

— | L

on
undefined

anner T-Spice 15,10 C:Documents 2nd Settingsispir My Documents|Tenner EDA Tannar Tools v15.1'SimlerionResults Inverts! Inverter_TestBench Mont=CarloAnslysis_Tnverter_TestBench_Joverter.sp 113:27 PM 1372011

e FaliTime

2.800n 2,85
undefined

annar T-Spice 15,10 C:Documents 20d Setings ispis My Documents Tenner EDA Tannar Tools v15.1 Jnwverter Iverter_TestBenchhonieCarloAnalysis_Inverter_TestBench_luverter.sp

' AvgDelay

|_|
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W-Edit: New Eye Diagram Chart

Use Chart > New Chart to create a new Eye chart and then add a trace to the chart

e

File Edit ‘iew Draw Chart 3Sstup  ‘Window Help

DAEHE Q> 8%

o ID[hartl (transient)

TransientAnalysis R | 1o - Spa 1120
In:
Title Timestamp ] s
{
Transientanal... 10:26:25 A... || | |‘

Eye (Eye)

add...

Eye Diagram Params
Period

2.4214577n

Offset

10.000000n

Chart ‘width

3.3900408n

[

Lifr o+ - R § & e P Manbranch. Executable is 41 days, 22 hours, 19 mins old.

Rl Az pddo s 2 | AN Bl B L

CDecumazs and Samings 'V bswa My Docoms zv\ame: DAV azow: T

1\l o il g VE g V0w Baae 2N e okl £

SELECT

MOYE SELECT

x|

102131 KMIZALL

Filter hd
E| VvV I & sz 318/318

Traces ™

In¥

MR :bulk: T
MMN1 :drgin: D
MMN1:gate:]
MMM 1 :source: T
MMNZ:bulk: T
MMNZ:dr sin: T
MMNZ:gate:]
MMN2:source: T
MMPL:bulk:T
MMPLidrain:D
MMP1igate:T
MIMPL:source:T
MMP2:bulk:T
TMIMP2:drain:T
MMPZ:gate: T
MMP2:source:T
N_LiY

N2

Out:¥

Outhly
OutP:y
RingFreg<Hz >
Timne:

wddiy
wWhiasineg:l
wWhiasiposi

WWtune: pos:1
Wwdd:neg:I
Wwdd:pos'1

41
21

Properties | Traces

# WED Z 421457684405n |
chart setattribute -eyeperiod 2.4214577n
chart setattribute -eyeperiod 2.4214577n

calc {[measure period -trace Out:¥ -threshold 2.2 -edge 1 -from 10n]/2}




W-Edit: New Chart Style Setup

= Use Setup > Chart Styles to set global default display characteristics for charts

- @Prefarences
O General
Chart Styles
O trace styles
O selection Styles
D Mause
+ [ Text Editor and Skylas

Save Load

Toffrom Folder:

Chart Skyles

Titles

Left Center Right

Ciptional elements

[¥ Show legend

Colors

Background: -
Margin:

arid:

i5rid

Direction: Bath hd

[v Show cursar tables

Bxes: -
Title: hd
Line skvle: Thin -

Reset ko default

= |

Close

~
-
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W-Edit: Copy or Save Charts as *. wmnf

= File >Image > Copy to clipboard or Save to file... will save the image as a Windows
MetaFile (.wmf)

= Windows MetaFile images can be then copied or imported to other applications.

— Windows MetaFile is a Vector and Bitmap file format that enables high resolution display and printing

_ wegit- [char2 (2] I W

Edit View Draw Chart Setup Window Help «
New e+ -2 3‘:
GF'E” 4 [P W I (= dugd
Image r Copy to clipboard {
E Save L Save to file... b
|—I Close
Export Chart Data..,

F T N VW W W W W IR WY

- "‘ ¢
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= Traces can now be defined by reading data from a file or from the clipboard.

W-Edit: Import / Export Traces

— To define a trace from a file, use TCL command trace define -file fileName -name traceName

— To define a trace from data in the clipboard, use TCL command trace define -clipboard —name traceName

Chart data can now be copied to Windows Clipboard and pasted to Excel or any other external program

— Right-click on the context menu of the selected trace and choose "Copy Data to Clipboard" command to copy the data to clipboard
— When executed, it runs the TCL command calc -clipboard, which will operate when there is a singly-selected curve

¥ W-Edit - [Chart1 (transient)]

© File Edit ‘iew Draw Chart Setup  Window Help
NR&E X RS- X
r Q ] D Chart1 (transient)

|TransientAnaIysis j

Title Timestamnp
TransientAnal... 10:26:25 A...

Add...

[Filter =1

I b nn i Ay R R Bk R R

Tarmez I-Spce 1510

1.500

1.000
|

. =+ — [ ® 3 g (K] ’v’ Main branch. Executable is 41 days, 22 hours, 29

R A= e zm e AN DD Bl

=IOy

PraT

CDecwmerd and S tting s s wa Wy Decumers Tare: FOAVare: Tesk vl 1 Gimuktenkesuls BingVCORng V0 TesfBerc KN mo.

Insert Plot
Delete Plat
Move Plot

Chart Properties. ..
Flot Properties. ..
Trace Style. ..

Expand Traces
Collapse Traces

EH2-C-|s :
{

g Home Insert Page Layout F-jrnlulas::
o <
‘_j ‘5 cut Calibri - - pé
53 Copy - <

| Pajte 7 Format Painter B 7 U-|g-|& v‘:
Clipboard Font {

Al - k|0 f

A B c D E=

o

1 0 0 3
2 | 6.25E-12 0.000126 ‘;
3 | 6.88E-11 0.015221 b
4 | 2.69E-10 0.220043 :
5 | 4.61E-10 0.580348 i
6 5.58E-10 0.786875 }
7 | 6.545-10 1.00745 2
8  T7.03E-10 1.27323 i
9 9.21E-10 1.59198 ;
10 1.00E-09 1.68042 E
11 1.09e-09 1.734 }
12 1.20E-09 1.77913 i
13 1.35e-09 1.81967 ;
14 1.55E-09 1.85734 :4
15 | 1.75e-09 1.8866 :‘
16 1.95e-09 1.31029 :
17| 2.15e-09 1.9275 ‘E
18 2.35E-09 1.9357 b
1% 2.55e-09 1.3422 5
20 2THERT s, B2, i n b b B0 s b g

N - 'b‘ .
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T-Spice: Simulation Files/Folders Can Now be

Easily Renamed

From the Simulation Manager, Right-Click the simulation and select Rename Output

Folder...

— Command was previously used to rename the database output folder

Delete Results deletes the results database and .tsim simulation command file

simultaneously

Setup Simulation, ..
Remove
Ermpty Lisk

Open Waveform, ..
Open Metlist. ..

Open Operating Point Results, ..

Open Simulation Log...
Open Assert Log...
Open Measure Log...
Open T3V Resuls, ..

Compare Resulks

Cpen Output Faolder, ..
Renama Oukput Faolder, ..
Delete Resulks

Finished

Input file

TransientAnal

w Hide

Stark Time) Dockmg wig

25 Februar™

Sekup Simulation, ..
Remaove
Ernpty Lisk

Open Waveform, ..
Cpen Metlist,

Open Operating Point Results. ..

Open Simulation Log. ..
Open Assert Log. ..
Qpen Measure Log. .,
Cpen Z5W Resdlks. ..

Compare Results

Open Qutput Folder,..
Rename Oukput Folder, .,

finished

- e &
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L-Edit: Improved Wire Drawing with Vias

= Manual routing is much faster with improved Via placement tools

— While drawing a wire, press the hot key to place a contact/via
Draw > Contacts > Down Key “[“ or Draw > Contacts > Up Key “1

— The command will now end the wire, place a contact/via, and start a new wire, all with one key stroke

= A Vias tab has been added to the Setup > Design dialog which allows for the setup of
contact/via cell connection layers and spacing

— The tab settings are used by Draw > Contacts > Down Key “[* or Draw > Contacts > Up Key “I* while drawing wires.
— Contacts created with Draw > Contacts > Define Contacts or Guarding are automatically added to this tab

Setup Design layout1 Bad

Technology ] Gnd ] Selection ] Drawing ] =ref filez {

Object Snap ] Interactive DRC ] Mode Highlighting Yiaz E
Pitches [Microns] 17 X r +
Lowwer Layer |lpper Layer Cell Fitch & Fitch
bdetall | | Metal? bA1-p42 25 25
.................. ot 24 o5 o5
bdetal3 bdetald b4 3-h4 25 25

s a i o e e on ay b oy e ol g ey R g R iy o o A e B N

~
-

b
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L-Edit: Snap to Intersection

= A new object snapping mode is available allowing you to snap to intersections

= Shnap to Intersection operates on all objects (boxes, polygons, wires, circles) and works
through hierarchy

|lmasEe o® o e e

Cell0*  Layoutl®

x‘) . ,o » ¢.“v“
: n \ QPR
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L-Edit: SDL Jump to Schematic

= When a net or instance is selected in the SDL Navigator in L-Edit, you can now highlight that
net or instance in S-Edit

— Use the SDL context Sensitive menu by right-clicking

U IF_Amp*[1]  RF_Amp.tdb*

SDL Mavigator

o]
F
¥ D ........ g=  Active MNet
3 [ Marker
#-[Q-gs  Flyline
S [ Highlight: Lawouk
#0er poe 3
A mEC R I 4
................. b
i m Ripup Met {
S {
+-O--0  Select Met }
#.[J-pe  Select Instance <
O« [ e {
O Mark Complete (‘
Power {
Delete b
4
Highlight Al :
e Collapse Tree b
P PP TPV PO A R PR T TR R PO Y PPN P

[ "\
e e
.
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HiPer Verify: DRC / Extract Speed Improvement

= The performance of HiPer Verify extraction is significantly improved for certain designs which utilize an
EXTENT calculation

— Several designs were extracted close to four times faster

= The BEVEL option in the Calibre SIZE command is now supported

~
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HiPer DevGen: Added Resistor Arrays

= The resistor generator in HiPer DevGen now has the ability to create resistor arrays

= SDL recognizes resistors in a netlist that have the same L and W and combines them into one resistor array

| HiPer Resistor_1

T-Cell narne:

Type: | M+ Paly

barameters L Cell0* RF_Amp.tdb* =3
Length: 10,000 microns
Wwidth: 2.000 microns
Mumber of segments: |3

Layout pattern

zeneration bype

Segment type: &' Resistor
|Series ﬂ

(" Makched resistor array

[v add an M-well shield under the resistor
W Add an extra column of contacts to the heads of the resistor )
Resistor parameter

[v Maintain uniform current flow direction through the resistor segments
I” Rotate the resistar by 90 deqrees

v add a dummy segment ta each end of the resistor

—
e
—

Generate | Cancel

v %
X
-
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